Problem Compiling llvm-gcc 4.2

Dear All,

I have been trying for days but still cannot break this barrier. May I get your help?

I have compiled llvm-2.1 successfully and make install. When I proceed with llvm-gcc-4.2-2.1, however, I keep getting linking error as attached. Some functions with totally different content conflict with each other in linking process.

That is a Linux box (Debian, with 2.6.23-1 Kernel) and I have already tried combinations of --disable-shared and/or --disable-multilib. It get stuck at the same point.

Thanks to Chris, I just realized Java is not supported but have no idea how to disable it. I have read the README.LLVM and got no clue. (Maybe my English is not good enough - I am not native speaker.)

Once again, thank you all for the great work. Idea of LLVM is really attractive to forget about.


You need to pass a --enable-languages=c,c++ to the initial configure invocation.


Try configuring with --disable-multilib



lots of problems compile llvm-gcc-4.2 from svn on x86_64. Just today I got
it to work by diabling bootstrap with "--diable-bootstrap". It might also be
needed to compile the 2.1 release version of llvm-gcc-4.2

Here is my configure command:
../llvm-gcc-4.2/configure --prefix=/opt/llvm --enable-llvm=/opt/llvm-top/build.llvm-2.1/ --enable-languages=c,c++ --enable-checking --disable-shared --disable-multilib --disable-bootstrap

That is for a debug build. I haven't try a relase build yet, but it should
only require removing the "--enable-checking" option.

Also there is a bug about this problem:

I added comments to that bug and a patch to get the latest svn revision to
build on Linux x86_64.

I am using Gentoo Linux with kernel 2.6.23 and gcc 4.2.2