Problem of building lldb on Mac

Hi,

I followed instructions in http://lldb.llvm.org/build.html to build lldb on Mac.

I opened “lldb/lldb.xcworkspace” in Xcode7.3.1, select lldb-tools scheme and build, I always got build error below. I have tried “brew install cmake” but the installed cmake version does not match what build script is looking for.

Questions:
Do I suppose to find and download 3.1.2 version of cmake to get this working? Do I miss anything? Thanks.

/bin/sh -c /Users/jeffreytan/Library/Developer/Xcode/DerivedData/lldb-acenblzastrxbocknmwzltsmlasq/Build/Intermediates/lldb.build/DebugClang/lldb-core.build/Script-261EECA21337D399001D193C.sh

[0/1] Re-running CMake…

/bin/sh: /usr/local/Cellar/cmake/3.1.2/bin/cmake: No such file or directory

FAILED: build.ninja

/usr/local/Cellar/cmake/3.1.2/bin/cmake -H/Users/jeffreytan/local/lldb/llvm -B/Users/jeffreytan/local/lldb/llvm-build/Debug+Asserts/x86_64

ninja: error: rebuilding ‘build.ninja’: subcommand failed

Traceback (most recent call last):

File “/Users/jeffreytan/local/lldb/scripts/Xcode/build-llvm.py”, line 340, in

build_llvm_if_needed()

File “/Users/jeffreytan/local/lldb/scripts/Xcode/build-llvm.py”, line 334, in build_llvm_if_needed

build_llvm(ninja_binary_path)

File “/Users/jeffreytan/local/lldb/scripts/Xcode/build-llvm.py”, line 328, in build_llvm

subprocess.check_call([ninja_binary_path], cwd=cmake_build_dir, env=cmake_environment())

File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py”, line 540, in check_call

raise CalledProcessError(retcode, cmd)

subprocess.CalledProcessError: Command ‘[’/Users/jeffreytan/local/lldb/ninja/ninja’]’ returned non-zero exit status 1

Nevermind, I was finally unable to build by “git pull” and “xcodebuild -configuration Debug”