Problem Running llvm-suite

Hi,

I'm trying to run the tests in llvm-suite, but I've run into trouble. First, I had the llvm-suite checkout in a directory alongside the llvm compiler checkout, but, when I ran "make" from llvm-suite, it complained about there not being a Makefile two levels above it, so I moved llvm-suite into the "test" subdirectory inside the llvm compiler checkout. I ran "make" again, but I got this:

[simmon12@maute llvm-suite]$ make
make[1]: Entering directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource'
make[2]: Entering directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource/UnitTests'
make[3]: Entering directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource/UnitTests/Vector'
make[4]: Entering directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource/UnitTests/Vector/SSE'
make[4]: *** No rule to make target `Output/sse.expandfft.linked.rbc', needed by `Output/sse.expandfft.linked.bc'. Stop.
make[4]: Leaving directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource/UnitTests/Vector/SSE'
make[3]: *** [all] Error 1
make[3]: Leaving directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource/UnitTests/Vector'
make[2]: *** [all] Error 1
make[2]: Leaving directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource/UnitTests'
make[1]: *** [UnitTests/.makeall] Error 2
make[1]: Leaving directory `/home/vadve/simmon12/llvm/llvm/test/llvm-suite/SingleSource'
make: *** [SingleSource/.makeall] Error 2

I already ran "./configure" inside llvm-suite, and I built a release build of the LLVM tools in the compiler checkout, so I'm not sure what the problem could be. Has anyone else had this problem and perhaps solved it?

--Patrick

You need to put it under the "projects" subdirectory. Read this:
http://llvm.org/docs/TestingGuide.html

It is perhaps a little confusing; looks like you stopped reading after the first "test suite" section. Keep going.

You will also need to specify where "llvm-gcc" and "llvm-g++" are. So you'll have to build LLVM, then build LLVM-GCC, link the created "gcc" and "g++" to the "llvm-gcc" and "llvm-g++", then reconfigure LLVM with the --with-llvmgccdir pointing to the LLVM-GCC you created.

-bw

Dale Johannesen wrote:

Hi,

I'm trying to run the tests in llvm-suite, but I've run into trouble.
First, I had the llvm-suite checkout in a directory alongside the llvm
compiler checkout, but, when I ran "make" from llvm-suite, it complained
about there not being a Makefile two levels above it, so I moved
llvm-suite into the "test" subdirectory inside the llvm compiler
checkout. I ran "make" again, but I got this:
    
You need to put it under the "projects" subdirectory. Read this:
http://llvm.org/docs/TestingGuide.html

It is perhaps a little confusing; looks like you stopped reading after the first "test suite" section. Keep going.

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
  

Thanks, Dale. I did what you said, and I can run the test suite now. Unfortunately, the tests all fail, with cc1 complaining about unknown debugging options being passed to it. The two possible causes I can think of for this are that I passed "--enable-optimized" when configuring LLVM, and that I used the GCC frontend located in /home/vadve/shared/llvm-gcc-4.2 instead of compiling the GCC frontend myself (I added the bin directory to my PATH). Do you think either of these things could be responsible?

Thanks again,
--Patrick

Patrick Simmons wrote:

Dale Johannesen wrote:

Hi,

I'm trying to run the tests in llvm-suite, but I've run into trouble.
First, I had the llvm-suite checkout in a directory alongside the llvm
compiler checkout, but, when I ran "make" from llvm-suite, it complained
about there not being a Makefile two levels above it, so I moved
llvm-suite into the "test" subdirectory inside the llvm compiler
checkout. I ran "make" again, but I got this:
    
You need to put it under the "projects" subdirectory. Read this:
http://llvm.org/docs/TestingGuide.html

It is perhaps a little confusing; looks like you stopped reading after the first "test suite" section. Keep going.

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
  

Thanks, Dale. I did what you said, and I can run the test suite now. Unfortunately, the tests all fail, with cc1 complaining about unknown debugging options being passed to it. The two possible causes I can think of for this are that I passed "--enable-optimized" when configuring LLVM, and that I used the GCC frontend located in /home/vadve/shared/llvm-gcc-4.2 instead of compiling the GCC frontend myself (I added the bin directory to my PATH). Do you think either of these things could be responsible?

Thanks again,
--Patrick

That should be /home/vadve/shared/llvm-gcc4.2, sorry for the typo. It was correct in my PATH.

--Patrick

I've never used that FE, I've always built my own. So it seems possible that's the problem.
I don't personally use -enable-optimized much, but other people do; that seems unlikely.

Dale Johannesen wrote:

I've never used that FE, I've always built my own. So it seems possible that's the problem.
I don't personally use -enable-optimized much, but other people do; that seems unlikely.

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
  

I downloaded the 2.4 release snapshot of llvm, llvm-gcc, and llvm-test, and the test suite runs correctly on that version, which solves my problem. Thanks for helping me with this.

--Patrick