Problem with building llvm-gcc

Hi,

I am trying to build the front end llvm-gcc 2.8 on 32-bit Ubuntu 10.04, using gcc 4.2.4. I was able to configure and build llvm-2.8 in the directory llvm-2.8-build. Here is the command I used to configure llvm-gcc build:

…/llvm-gcc-4.2-2.8.source/configure --enable-checking --disable-bootstrap --disable-multilib --enable-llvm=/home/ghoang/llvm-test/llvm-2.8-build/ --enable-languages=c

And this is the error that I got:

checking for i686-pc-linux-gnu-gcc… /home/ghoang/llvm-test/llvm-gcc-2.8-build/./gcc/xgcc -B/home/ghoang/llvm-test/llvm-gcc-2.8-build/./gcc/ -B/usr/local/i686-pc-linux-gnu/bin/ -B/usr/local/i686-pc-linux-gnu/lib/ -isystem /usr/local/i686-pc-linux-gnu/include -isystem /usr/local/i686-pc-linux-gnu/sys-include
checking for C compiler default output file name… configure: error: C compiler cannot create executables
See config.log' for more details. make[1]: *** [configure-target-libmudflap] Error 1 make[1]: Leaving directory /home/ghoang/llvm-test/llvm-gcc-2.8-build’
make: *** [all] Error 2

To avoid this error, I tried adding the flag --disable-libmudflap and I got a new error:

checking for library containing strerror… configure: error: Link tests are not allowed after GCC_NO_EXECUTABLES.
make[1]: *** [configure-target-libiberty] Error 1
make[1]: Leaving directory `/home/ghoang/llvm-test/llvm-gcc-2.8-build’
make: *** [all] Error 2

I also tried building version 2.9 but also encountered the same error. It seems that the setup of my system is missing some libraries. Any recommendation to solve these problems would be appreciated.

Thank you,

Giang

try --disable-libmudflap when you config llvm-gcc FE:)

Thank you, I did try that and got the following error:

checking for library containing strerror… configure: error: Link tests are not allowed after GCC_NO_EXECUTABLES.
make[1]: *** [configure-target-libiberty] Error 1
make[1]: Leaving directory `/home/ghoang/llvm-test/llvm-gcc-2.8-build’
make: *** [all] Error 2

I also tried adding --disable-libiberty but make would fail even earlier with the following error:

make[1]: Entering directory /home/ghoang/llvm-test/llvm-gcc-2.8-build' make[2]: Entering directory /home/ghoang/llvm-test/llvm-gcc-2.8-build/fixincludes’
make[2]: *** No rule to make target ../libiberty/libiberty.a', needed by full-stamp’. Stop.
make[2]: Leaving directory /home/ghoang/llvm-test/llvm-gcc-2.8-build/fixincludes' make[1]: *** [all-fixincludes] Error 2 make[1]: Leaving directory /home/ghoang/llvm-test/llvm-gcc-2.8-build’
make: *** [all] Error 2

Giang

Thank you, I did try that and got the following error:

checking for library containing strerror... configure: error: Link tests are
not allowed after GCC_NO_EXECUTABLES.
make[1]: *** [configure-target-libiberty] Error 1
make[1]: Leaving directory `/home/ghoang/llvm-test/llvm-gcc-2.8-build'
make: *** [all] Error 2

I also tried adding --disable-libiberty but make would fail even earlier
with the following error:

you can NOT --disable-libiberty, gcc need it.

Sorry, I'm not a llvm-gcc user, maybe Dragonegg or Clang will be OK,
I'm a clang user.