Problem with Ubuntu 18.04: Python LLDB not working

Hello,

I had a few machines on 16.04 with LLDB 8 an all was going nicely.
I have ported a bunch to 18.04, and I have the same problem on all of them: the script command in lldb doesn’t work, and so my custom formatters for C++ aren’t working.
I have tried LLDB 8, LLDB 9, and LLDB 10, to no avail.

Recently, pruned everything related to lldb/llvm then installed fresh:

$ sudo apt install lldb-9 python3-lldb-9

$ sudo apt list --installed | /bin/grep “ll[d|v]”

liblldb-9/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
libllvm6.0/bionic,now 1:6.0-1ubuntu2 amd64 [installed]
libllvm8/now 1:8.0.1~svn369350-1~exp1~20190820121219.79 amd64 [installed,local]
libllvm9/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
lldb-9/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed]
llvm-9/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
llvm-9-dev/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
llvm-9-runtime/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
llvm-9-tools/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
python-lldb-9/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed,automatic]
python3-lldb-9/unknown,now 1:9~+20191125111505+62a16ca77d6-1~exp1~20191125222100.93 amd64 [installed]

$ /usr/bin/lldb-9
(lldb) script
Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘run_one_line’ is not defined
Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘run_python_interpreter’ is not defined

I have tried to read the archive (which isn’t searchable as far as I can tell) and went a few months back, found a couple of posts including one that linked to https://bugs.llvm.org/show_bug.cgi?id=43830 but this should be in 9.0.1 too…

I’m at a loss, and this is hindering my debugging since I’m missing my usual formatters (such as formatters for Qt etc).

Can someone help please?

Thank you,