Problem

Hello, Willow

C:\Downloads\llvm-gcc4.2-2.3-x86-mingw32\llvm-gcc4.2\bin>llvm-gcc a.c -o a
a.c:1: error: bad value (generic) for -mtune= switch

Something is really broken at your side. Are you running Vista?

Yes I am running Vista. I tried running the program as an Administrator but I get the same error. What is a valid -mtune argument I can try?
Thanks,
Willow

Anton Korobeynikov wrote:

generic *is* a valid value for mtune; however, it's was added to gcc
relatively recently. This is only a rough guess, but the most likely
issue is that llvm-gcc is somehow picking up version of gcc bundled
with mingw from the path. Maybe try something like the following and
see if it works? PATH="" ./llvm-gcc a.c -o a

-Eli

Hi Eli,
You're absolutely right, I have gcc 3.4.2 (mingw-special) in my PATH and that's what the problem is.
But when I tried
    SET PATH=
    llvm-gcc a.c -o a
I get this error:

C:\Downloads\llvm-gcc4.2-2.3-x86-mingw32\llvm-gcc4.2\bin>llvm-gcc a.c -o a
llvm-gcc: CreateProcess: No such file or directory

What is the proper way to install LLVM? I got llvm-gcc4.2-2.3-x86-mingw32.tar.bz2 and llvm-2.3-x86-mingw32.tar.bz2 and decompressed them, and copied llvm-2.3/bin to the other bin directory. Am I supposed to copy some executable files or make "symbolic links" or whatever as part of the installation process?
Willow

Eli Friedman wrote: