Problems buildign llvm/clang

Hi,

i've started fiddling with clang since boost'con thanks to Sebastian.
However, after following the easy install step, i can't get even llvm to build. It faisl with :

make[3]: Entering directory `/home/joel/Documents/dev/llvm/llvm/bindings/ocaml/llvm'
/bin/sh: /usr/local/bin/ocamldep: not found
llvm[3]: Compiling llvm_ocaml.c for Debug build
llvm[3]: Building Debug libllvm.a
llvm[3]: Compiling llvm.mli for Debug build
llvm[3]: Compiling llvm.ml for Debug build
llvm[3]: Archiving llvm.cma for Debug build
llvm[3]: Compiling optimized llvm.ml for Debug build
Corrupted compiled interface
/home/joel/Documents/dev/llvm/llvm/bindings/ocaml/llvm/Debug/llvm.cmi
make[3]: *** [/home/joel/Documents/dev/llvm/llvm/bindings/ocaml/llvm/Debug/llvm.cmx] Error 2
make[3]: Leaving directory `/home/joel/Documents/dev/llvm/llvm/bindings/ocaml/llvm'
make[2]: *** [all] Error 1
make[2]: Leaving directory `/home/joel/Documents/dev/llvm/llvm/bindings/ocaml'
make[1]: *** [ocaml/.makeall] Error 2
make[1]: Leaving directory `/home/joel/Documents/dev/llvm/llvm/bindings'
make: *** [all] Error 1

ocaml is install and lies in the proper directory which is also in my PATH. ANy idea with this fail ?

PS : if this should go to the LLVM list, I apologize for the noise

Hi Joel,

As a workaround, pass --disable-bindings to configure. What platform and version of ocaml are you using?

— Gordon

It looks like something is wrong with your ocaml installation. Try
configuring LLVM with --disable-bindings.

- Daniel