Problems building CLang on Ubuntu with gcc, g++

Hi,
I have been trying to compile CLang from my Ubuntu machine.
There is something that is very strange.

The first time I tried on this machine, I was uing gcc-4.8 and g±4.8.
Somehow make was producing errors very early which indicated that gcc was not using std=c++11 (at least implicitly)
because nullptr was not recognised, std::move didnt exist and other error messages of an old compiler.
Yet gcc --version reported 4.8.1 and so did g++.

I fidled with the Makefile.config to add this compler option, reran configure and it looked as if these things were a problem of the past.
Should not .configure have overwritten the Makefile.config anyway?
Anyway something happenned today: the output directories Debug+Asserts containing the executables disappeared
as did Release+Asserts… Now I might be getting very tired and am getting very little sleep and hence making lots of stupid mistakes.
But in the meantime I had copied the executables to /usr/local/bin
I tried running the make again and I ran into exactly the same original problem: most files were not compiling.
Well, at least I have the executables. I’d like to have the appropriate include files in the right place or else
compiling hello world will tell me that stddef is not found. By the way there are several copies of stddef.h in there, which one do I take?
I thought a good place to put the includes might be something inside /usr/local. Where do I go looking for these headers?
Thankyou for your attention