[PSA] FunctionOpInterface "type" attribute was renamed to "function_type"

Along with this, the getType() method was renamed to getFunctionType(). Outside of updating the C++ API of getType, it shouldn’t have too much of an impact (aside from any uses of generic format).

The intent behind this was captured a bit in the revision (avoid confusion with the Value::getType() methods that get used/generated).