Registering '-march=' option for LLC

Thank you for replying to me.
As you recommended, I modified configure.ac in autoconf folder. But I’m not sure about how to regenerate configure. Sorry…
I tried to follow the way introduced in README.TXT in the autoconf folder. It asks me to run autoupdate on all the m4 and configure.ac. And then it asks me to regenerate configure script with AutoRegen.sh. However, when I did that, I got an error like this:
Your libtool was not detected as being 1.5.10
I think it's because library does not seem to be linked with my tool.
Would you mind helping me again to resolve this problem?
Thank you very much.

Seung Jae Lee

While making my code for LLVM backend, I'd indeed like to
convert HLL to the text assembly code for my new
architecture.
I registered my target through
RegisterTarget<XccTargetMachine> X("xcc", "XCC");
in XccTargetMachine.cpp.

Your response:
Make sure that the library is being linked into your tool. This requires adding code to llvm/autoconf/configure.ac (search for TARGETS_TO_BUILD, add yours). Then regenerate configure, then rerun configure, then rebuild llc.

You need to have the latest version of libtool (1.5.22). You may get similar errors for other things (autoconf, aclocal, etc). If so, upgrade those as well.

-Tanya

> Thank you for replying to me. As you recommended, I modified
> configure.ac in autoconf folder. But I’m not sure about how to
> regenerate configure. Sorry…
> I tried to follow the way introduced in README.TXT in the autoconf
> folder. It asks me to run autoupdate on all the m4 and configure.ac. And
> then it asks me to regenerate configure script with AutoRegen.sh.
> However, when I did that, I got an error like this:
> Your libtool was not detected as being 1.5.10

You need to have the latest version of libtool (1.5.22). You may get
similar errors for other things (autoconf, aclocal, etc). If so, upgrade
those as well.

That's actually not quite correct. You need to have exactly libtool
1.5.10. No other version will work. The reason is that we have
incorporated the 1.5.10 version of the ltdl library (and autoconf
checks) into LLVM. Perhaps its time to upgrade, but 1.5.10 is what LLVM
expects and works with.

> Thank you for replying to me. As you recommended, I modified > configure.ac in autoconf folder. But I’m not sure about how to > regenerate configure. Sorry…
> I tried to follow the way introduced in README.TXT in the autoconf > folder. It asks me to run autoupdate on all the m4 and configure.ac. And > then it asks me to regenerate configure script with AutoRegen.sh. > However, when I did that, I got an error like this: > Your libtool was not detected as being 1.5.10

You need to have the latest version of libtool (1.5.22). You may get similar errors for other things (autoconf, aclocal, etc). If so, upgrade those as well.

That's actually not quite correct. You need to have exactly libtool
1.5.10. No other version will work. The reason is that we have
incorporated the 1.5.10 version of the ltdl library (and autoconf
checks) into LLVM. Perhaps its time to upgrade, but 1.5.10 is what LLVM
expects and works with.

Ah sorry. Is this 1.8? LLVM 1.9 requires 1.5.22. I forgot we haven't technically released that yet
:wink:

-Tanya