Removing old makefiles before 3.8 branching

Hi!

If I'm not mistaken old makefiles are not supported in 3.8. If this is
a case, i think till be good idea to remove them before 3.8 branching.

Eugene.

They’re deprecated in 3.8. Chris and I are making plans for when (after branch) the removal happens.

Eugene Zelenko via llvm-dev <llvm-dev@lists.llvm.org> writes:

If I'm not mistaken old makefiles are not supported in 3.8. If this is
a case, i think till be good idea to remove them before 3.8 branching.

The plan is to remove the autoconf/makefile build *after* the 3.8
branch. It will be deprecated (but not removed yet) for the 3.8 release.

The thread with the plan is here:

  http://lists.llvm.org/pipermail/llvm-dev/2015-November/092150.html

Any chance I could beg a couple of week extension on the removal? We’re tracking ToT and ran into some minor snags getting switched over to cmake. Having an extra couple of weeks would be really useful.

Philip

I will be sending out an RFC with a timeline for removal later today. It will not be immediately after the branch. I’m planning a few weeks of grace so that bot maintainers (and anyone else who still needs to) can migrate off autoconf.

-Chris

I hope they may be removed after 3.8.0-final is released.

2016年1月8日(金) 4:08 Chris Bieneman via llvm-dev <llvm-dev@lists.llvm.org>:

Could you elaborate here?