Replacing system libc++

Hi,

I wonder why updating system libc++.1.0.dylib, libc++abi.1.0.dylib, libunwind.1.0.dylib on macOS using libs from 8.0.1 isn’t doing it, I’ve i386 + x86_64 dylibs, last time I updated with 5.0.x’s version, currently it stops at 2nd step gray screen with apple logo and cursor in top-left? The only difference I noticed is old libc++.1.0.dylib using ‘/usr/lib/libc++abi.dylib (compatibility version 1.0.0, current version 49.1.0)’ that’s shown with otool and new one not having it?

Greets