RESOLVED: [LLVMbugs] [Bug 451] Libtool does not create libNAME.$(SHLIBEXT) files when building dynamic libs

I'm forwarding this bug resolution because it has a pretty wide impact on LLVM developers. This bug (451) has been resolved (well, works for me anyway). If you have reconfigured your build tree since October 4th, you need to reconfigure again. The bug produced shared objects that don't have a .so extension. Reconfiguring will fix this problem. The notes below show what was needed to be fixed.

FOR THOSE RUNNING AutoRegen.sh:

For this to work reliabily, you MUST have the following auto* tools in your
path:

autoconf: 2.59
aclocal: 1.9.2
autoheader: 2.59
automake: 1.9.2
libtool: 1.5.10

Other combinations *might* work, but its unlikely (I've tested nearly all of them). Note that automake isn't needed by AutoRegen.sh UNLESS you're trying out the --with-automake flag (on AutoRegen.sh). However, you still MUST install automake 1.9.2 even if you're not using --with-automake because that is how you get aclocal 1.9.2 which is needed by autoconf.

Reid.