RFC: better method names

So, after some discussion here, it became clear that at least one method
has a very poor name. Attached is a patch that should clear up this
confusion. Some comments and enum values obviously would need to be
updated.

Andrew :wink:

patch (21.5 KB)

haha, :slight_smile:

-Chris