[RFC] Replace `unsigned VF` with `ElementCount VF` [NFCI]

Francesco,

   I think this is a good approach. ElementCount is the value that the vector types themselves use to describe their size, we should just use that everywhere we talk about the sizes of vectors. This seems like a good start, and will allow us to add scalable vector functionality one bit at a time.

Thanks,
   Christopher Tetreault