[RFC] Replace `unsigned VF` with `ElementCount VF` [NFCI]

Hi,

The feedback I received so far on this patch has been positive. Therefore, I have removed the `WIP` label and change it into a patch for which I want to do the formal review process (all comments so far have been addressed).

Kind regards,

Francesco