[RFC] Requiring python 2.6

So far two bots have complained about 2.7 (but have 2.6):

http://bb.pgr.jp/builders/clang-i686-cygwin-RA-centos6/builds/12836/steps/configure/logs/stdio

http://lab.llvm.org:8011/builders/llvm-s390x-linux1/builds/12002/steps/configure/logs/stdio

Should we just upgrade those bots or reduce the requirement to 2.6?

I've now upgraded the SystemZ bot to Python 2.7.

Bye,
Ulrich