Could those two be subdirectories of one “Machine-Related-Stuff” directory?
Where MachineStuff is something meaningful :).
That way, they keep a logic bound, more formal than the naming convention.
Unless there will be many subdirectories, it seems slightly better to flatten out the layer.
I strongly prefer breaking it out into subdirectories. There are a bunch of reasons:
- It will grow.
- Without it, we cannot have separate libraries, which will lose some options for shrinking the size of libraries.
- Without separate libraries we can’t as easily enforce the layering separations between these things. For example, making this split will be extremely hard currently because there is a lot of inappropriate dependencies that will block splitting things out.
However, “IR” and “Passes” cover only two of the things in CodeGen. There is also the implementation of a lot of common infrastructure used by targets’ code generators.
My initial suggestion would be to just sink CodeGen into Machine/CodeGen, add the …/IR and …/Passes directories, and then start extracting things from CodeGen into the two more narrow directories. I think there is likely some stuff that should continue to live in a “code generator” infrastructure directory as it is neither part of the machine IR, nor is it part of any particular pass.
My suggested layering would be:
Passes depend on IR, CodeGen depends on both Passes and IR. The idea is that anything passes require should be embedded into the IR.
However, this won’t currently work. There are things that seem to be parallel but independent of the machine IR and are used by any machine passes. There are also things that clearly use the machine passes. Currently, I’m not sure how to cleanly divide this library up without really significant refactoring of every part of the code generator.
While I would like to see this happen, is it really a good idea to put this in the critical path of getting MIR serialized and deserialized?
Also, if we’re getting crazy here, CodeGen in clang should be renamed to IRGen, AsmPrinter should be renamed to MCGen, and SelectionDAG should be replaced
I’m happy to actually do the CodeGen → IRGen rename. I actually built the change but didn’t submit it because of the concerns of some out-of-tree users of Clang. I still have all the perl scripts and such I used sitting around.