RPM build failure on CentOS

I'm trying to get an RPM build completed on CentOS. I've wandered through a bunch of minor issues as I navigated the Makefile and Makefile.rules files to get through some odd problems that appeared to be with my CentOS environment. I can build an LLVM install just fine.

make dist finishes cleanly, but make dist-check isn't.

I am trying to only build the Unix target, this one is a bit vexing. The regengine.inc file is definitely in the .src directory and if I hand copy it to the .obj directory I still get the same error.

llvm[2]: Compiling regexec.c for Release build
/root/software/llvm-3.0.obj/_distcheckdir/llvm-3.0/lib/Support/regexec.c:82:25: error: regengine.inc: No such file or directory
/root/software/llvm-3.0.obj/_distcheckdir/llvm-3.0/lib/Support/regexec.c: In function ‘llvm_regexec’:
/root/software/llvm-3.0.obj/_distcheckdir/llvm-3.0/lib/Support/regexec.c:159: warning: implicit declaration of function ‘smatcher’
/root/software/llvm-3.0.obj/_distcheckdir/llvm-3.0/lib/Support/regexec.c:161: warning: implicit declaration of function ‘lmatcher’
make[2]: *** [/root/software/llvm-3.0.obj/_distcheckdir/build/lib/Support/Release/regexec.o] Error 1
make[2]: Leaving directory `/root/software/llvm-3.0.obj/_distcheckdir/build/lib/Support'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/root/software/llvm-3.0.obj/_distcheckdir/build'
make: *** [dist-check] Error 2
[root@pg73-v2 llvm-3.0.obj]# find . -name "regengine.inc"
[root@pg73-v2 llvm-3.0.obj]# find ../llvm-3.0.src/ -name "regengine.inc"

Any thoughts? (I am rather new to building RPMs btw so there is definitely a possibility I am being naive about something or some simple tool that is missing from my environment, I just added ocaml to my environment, that seemed to be causing a hiccup late in the process that I didn't catch earlier).

Paul Monday
Parallel Scientific, LLC.