RTL dialect -> "hw" dialect

Per discussion long ago, we converged on agreement that we should rename the RTL dialect to “hw” for hardware.

Assuming no objections, I’ll try to tackle this this coming weekend. Such a change will touch a bunch of code, so this is a warning that it is unwise to have big out of tree patches that mention the rtl dialect if you don’t want lots of merge fun :wink:

Noted, thanks for the heads up!

This is done, please let me know (or directly fix) any bugs you see in the transition. Thx!

1 Like