Running external build tool in Xcode?

Hi everyone.
I am using Mac OS X to inspect the llvm source code.
Although the make command works perfectly when compiling the source code, the Xcode tool prompted me:

Makefile:26: Makefile.config: No such file or directory

Makefile:58: /Makefile.rules: No such file or directory

I downloaded the latest SVN code from the web site, built it without any modification in Xcode context. Xcode couldn’t build even a single line of code. It just said it could not find the Makefile.
This may be caused by incorrect path setting.
If anyone here has came across this problem, would you please tell me how to set up the project properly in Xcode environment?
Any tip or advise is highly appreciated. Thank you very much for any help.

Please try configuring your tree first, according to the ‘getting started guide’. Also note that the Xcode project files are often out of date and may not work for building the code, most mac developer use make on the command line.

-Chris

Chris Lattner <clattner@apple.com> writes:

I am using Mac OS X to inspect the llvm source code.
Although the make command works perfectly when compiling the source
code, the Xcode tool prompted me:

Please try configuring your tree first, according to the 'getting
started guide'. Also note that the Xcode project files are often out
of date and may not work for building the code, most mac developer use
make on the command line.

AFAIK, CMake supports XCode. I have no idea about how adequate the
current LLVM CMake build specification is for XCode, but maybe it is
worth a try.

Hi,

you have to choose the right settings.
1. the target "LLVM" hast to be activated
2. in menu Project-> Edit Active Target "LLVM" choose the root directory of your LLVM installation. ( for instance "$(SRCROOT)/../" or a hard coded path).

I don't know if this will solve your problems, but it solved mine.

Ciao,
Nico