running spec2006 with clang

I used the suite with clang 3.3 a few months ago.
If I remember correctly, I ran into the same error seen here:
http://lists.cs.uiuc.edu/pipermail/llvmdev/2010-November/036013.html
Although it doesn’t seem to be a problem with the frontend, adding -std=gnu89, as suggested, fixed everything for me.

H.

-std=gnu89 is not valid for c++ what did you use for that? tia. Reed

I think the point here is that this is the default std for GCC but not
Clang, so you have to force clang to behave like GCC. For C++, you'll have
to force whatever default GCC has for it's C++ standard.

Though, GCC 4.8 is getting very close to Clang's behaviour, so those issues
are bound to disappear in the near future.

cheers,
--renato

right, but what option in clang++ forces it close to g++ for running spec2006 ? for clang it is apparent -std=gnu89 i understand that we have it configured already for test-suite but I also need to be able to run this standalone (outside of test-suite).

There were build failures on some spec2006 benchmarks with clang. In order to build 400.perlbench, we added -std=gnu89 option.

464.h264ref needed the flag –fsigned-char set, whereas 456.hmmer needed –funsigned-char.