s/ComputeMaskedBits/ComputeKnownBits/g ?

I've always found the name ComputeMaskedBits a bit unintuitive, and
since r154011 it's even worse because there is no masking going on
whatsoever:

http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html

Is there any appetite for a global rename to ComputeKnownBits? Or any
other better names?

Thanks,
Jay.

I like computeKnownBits. Sorry for failing to update the name and
comments with the original change.

Thanks!
Rafael

+1. We should fix the case if we're changing the name anyway.

Makes sense to me.

-Chris

Oh yeah, the comments. I've updated them first in r208757.

I'll prepare a patch to rename ComputeMaskedBits to computeKnownBits.
Do I have to worry about any projects outside of the "llvm" svn
module? Or document the name change, in case any out-of-tree code
needs updating?

Thanks,
Jay.

N.B. this change affects most targets, since I'll rename their
computeMaskedBitsForTargetNode methods.

Jay.

Oh yeah, the comments. I've updated them first in r208757.

Thanks! Btw, when you rename the function, please also drop the name
from the comments.

I'll prepare a patch to rename ComputeMaskedBits to computeKnownBits.
Do I have to worry about any projects outside of the "llvm" svn
module? Or document the name change, in case any out-of-tree code
needs updating?

You can send an email to llvmdev, but it should be obvious what
changes need to be done to any out of tree code, so I don't think you
need to.

Thanks,
Rafael

OK. All done in r208811.

Thanks,
Jay.