scan-build: no reports generated

Hi-

We are trying to add Clang static analyzer to some of our Mac builds. We have a newer build using Xcode on MacOS 10.7.0. That build runs great and I get output.

However, I have an older build using make on MacOS 9.8.0. I cannot get this one to work. Everything I try, I get:

scan-build: Removing directory ‘/private/tmp/clangScanBuildReports/2011-06-22-2’ because it contains no reports.

I’ve tried the Clang download from:

http://clang-analyzer.llvm.org/

And even built the tool using:

http://clang.llvm.org/get_started.html

And same result. Could the older OS be the issue? Any other things could be wrong? So far I couldn’t find a solution on the web.

Thanks!

Kathy

To be clear, you are referring to a pre-Darwin MacOS? That is completely unsupported. The earliest version of MacOS that the analyzer has been tested on is 10.5.

Somehow, I don't think so. I think she really means *Darwin* 9.8.0 (Mac
OS X 10.5.8).

Chip

Makes sense.

Kathy: is your Leopard machine a PPC machine? The binaries on clang-analyzer.llvm.org are Intel only.

Hi Ted,

Thanks so much for the response. Sorry for the confusion. I was getting the 9.8.0 from uname output. Yes, I have Mac OS X 10.5.8. It is running 2 - 2 GHz Dual-Core Intel Xeon processors.

So should it work in this environment?

Thanks!

Kathy

I believe it should still work, but I have not tested it in on Leopard in long time.

Can you email me (privately) your build log when you use scan-build with the ‘-v -v’ options (extra verbosity).