Self-host buildbot

Hi,

I’m trying to set up a self-host ARM bot and am following the ClangBuilder with two stages, copying the config from other bots, but I can’t find my way around the configure options…

This is my config:

Cortex-A9 check-all self-host

{‘name’: “clang-native-arm-cortex-a9-self-host”,
‘slavenames’:[“linaro-panda-02”],
‘builddir’:“clang-native-arm-cortex-a9-self-host”,
‘factory’ : ClangBuilder.getClangBuildFactory(
stage1_config=‘Release+Asserts’,
stage2_config=‘Release+Asserts’,
useTwoStage=True,
clean=False,
test=False,
extra_configure_args=[‘–build=armv7l-unknown-linux-gnueabihf’,
‘–host=armv7l-unknown-linux-gnueabihf’,
‘–target=armv7l-unknown-linux-gnueabihf’,
‘–with-cpu=cortex-a9’,
‘–with-fpu=neon’,
‘–with-float=hard’,
‘–enable-targets=arm’])},

This way, the install process will copy to:

llvm.install.1/bin/armv7l-unknown-linux-gnueabihf-clang

but the next configure step will look for:

llvm.install.1/bin/clang

While, if I comment out the --build options, the reverse happens, and still doesn’t find the correct binary. Commenting all options lead me back to behaviour #1 again.

I tried fiddling with the --host and --target, to no avail. Does anyone know how to make stage 1 install and stage 2 configure agree on the name of the binary?

cheers,
–renato