specint2000 as external tests

Hi All,

I am trying to configure llvm so with test-suite enabled. I have downloaded the test-suite. Spec 2000 benchmarks sources are plugged in speccpu2000 at
$LLVM_SRC_ROOT/projects/test-suite-externals/speccpu2000/benchspec

e.g.: 164.gzip dir is $LLVM_SRC_ROOT/projects/test-suite-externals/speccpu2000/benchspec/164.gzip

My configure command is:
…/configure --disable-optimized --enable-assertions --enable-spec2000 --with-llvmgccdir=

But with this configure command I still get

Hi Daya,

checking for spec2000 benchmark sources... no, not found in
$LLVM_SRC_ROOT/projects/test-suite-externals/speccpu2000/benchspec

I have 164.gzip at
$LLVM_SRC_ROOT/projects/test-suite/External/SPEC/CINT2000/164.gzip
and it seems to work.

Ciao, Duncan.

Hi Duncan,

Do you have sources also in the $LLVM_SRC_ROOT/projects/test-suite/External/SPEC/CINT2000/164.gzip?

The following is content of above directory in my case. I have copied the CINT2000 sources in this directory manually.

$ls -1 $LLVM_SRC_ROOT/projects/test-suite/External/SPEC/CINT2000/164.gzip

164.gzip.reference_output
164.gzip.reference_output.small
compile_info
compile_parms
exec_info_input1
exec_info_input2
exec_info_input3
exec_info_input4
exec_info_input5
exec_info_input6
exec_info_input7
input1
Makefile
make_src_164.gzip
output1
output2
output3
output4
output5
output6
output7
patched_src
src

Does this look ok to you?

Thanks for your help.
Daya

My source directory wasn’t correct but now I have a correct test directory structure.

$ls -1 ~/tmp/speccpu2000/benchspec/CINT2000/164.gzip/
data

docs
exe
result
run
Spec
src
version

I reconfigured the llvm with …/configure --prefix=/home/dskhudia/tmp/llvm-install --with-llvmgccdir=/home/dskhudia/tmp/llvm-install --with-externals=/home/dskhudia/tmp

Now I can execute the make -C 164.gzip but I am getting the following error.

/home/dskhudia/tmp/llvm-2.9/obj/projects/test-suite/…/…/…/projects/test-suite/RunToolSafely.sh 500 /home/dskhudia/tmp/llvm-2.9/obj/Release/bin/llvm-ld -info-output-file=/home/dskhudia/tmp/llvm-2.9/obj/projects/test-suite/External/SPEC/CINT2000/164.gzip/Output/164.gzip.llvm.bc.info -stats -time-passes Output/164.gzip.linked.bc \

-lc -o Output/164.gzip.llvm
llvm-ld: error: Cannot find library ‘c’

Does anyone where is this c library expected?

Thanks
Daya

/home/dskhudia/tmp/llvm-2.9/obj/projects/test-suite/../../../projects/test-suite/RunToolSafely.sh
500 /home/dskhudia/tmp/llvm-2.9/obj/Release/bin/llvm-ld
-info-output-file=/home/dskhudia/tmp/llvm-2.9/obj/projects/test-suite/External/SPEC/CINT2000/164.gzip/Output/164.gzip.llvm.bc.info
<http://164.gzip.llvm.bc.info> -stats -time-passes Output/164.gzip.linked.bc \
  -lc -o Output/164.gzip.llvm
llvm-ld: error: Cannot find library 'c'

Does anyone where is this c library expected?

Are you on ubuntu or recent debian?

Ciao, Duncan.

llvm-ld: error: Cannot find library 'c'

I'm using this hack, but of course there should really be a correct fix for
this "gcc multi-arch" issue.

--- test-suite/Makefile.programs (revision 134059)
+++ test-suite/Makefile.programs (working copy)
@@ -362,6 +362,7 @@
  # Disable asm-verbose. This can slow down compilation and is not what the
  # compilers default to using.
  LLCFLAGS += -asm-verbose=false
+LLVMLD_FLAGS += -L/usr/lib/x86_64-linux-gnu/

  # If the program requires exception handling support, enable (potentially
  # expensive) support for it.

I am using Ubuntu 11.04 and the hack that you have mentioned works.

Thanks
Daya