successfully bootstraped on a i686-linux-gnu

Building with --enable-llvm failed latter on when compiling libojc:

configure:5099: checking for exception model to use
configure:5131: /home/rafael/dev/gcc/build/gcc/xgcc
-B/home/rafael/dev/gcc/build/gcc/ -B/i686-pc-linux-gnu/bin/
-B/i686-pc-linux-gnu/lib/ -isystem /i686-pc-linux-gnu/include -isystem
/i686-pc-linux-gnu/sys-include -c -xobjecti
ve-c -fgnu-runtime -fobjc-exceptions -S conftest.c >&5
WARNING: EH not supported yet!
configure:5134: $? = 0
configure:5155: error: unable to detect exception model

To work aroud the problem I edited gcc/objc/config-lang.in and removed
the comment from the line
#target_libs=target-libobjc

With this change it is again possible to build without objc. The
complete configure line was

../llvm-gcc4-1.7.source/configure --prefix=$CFEINSTALL
--enable-languages=c,c++ --program-prefix=llvm-
--enable-llvm=/home/rafael/dev/obj/ --enable-checking

Best Regards,
Rafael

This is the right fix, thanks! I've applied it to the main llvmgcc tree.

-Chris

Hi,

I recently bootstrapped gcc4 frontend on a i686-linux-gnu too.
As I notice, if the llvm "tools-only " was build with srcdir != objdir ,
the building of llvm-gcc4-1.7.source encountered mistakes of unable to find some header files.
So I just edited llvm-gcc4-1.7.source/gcc/Makefile.in and a line like this:

INCLUDES += -I$(LLVMOBJDIR)/include

With this change, the building errors were gone.
Is this the right hack? Thanks.

Nai

I recently bootstrapped gcc4 frontend on a i686-linux-gnu too.
As I notice, if the llvm "tools-only " was build with srcdir != objdir ,
the building of llvm-gcc4-1.7.source encountered mistakes of unable to find some header files.
So I just edited llvm-gcc4-1.7.source/gcc/Makefile.in and a line like this:

INCLUDES += -I$(LLVMOBJDIR)/include

With this change, the building errors were gone.
Is this the right hack? Thanks.

Yup, that's right!

-Chris

To work aroud the problem I edited gcc/objc/config-lang.in and removed
the comment from the line
#target_libs=target-libobjc

With this change it is again possible to build without objc. The
complete configure line was

../llvm-gcc4-1.7.source/configure --prefix=$CFEINSTALL
--enable-languages=c,c++ --program-prefix=llvm-
--enable-llvm=/home/rafael/dev/obj/ --enable-checking

This is the right fix, thanks! I've applied it to the main llvmgcc tree.

-Chris

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris