Test failures

Hi,
Two days ago, the test suite started failing. Initially there were
hundreds of failing tests; now only seven remain.
They appear to be related to SystemZ.

Here's the last failed test:

Nope, this triple is correct. The canonicalization of the triple (actually
a quadruple) always print all fields, empty or not.

I'm not sure what's going on, though. How are you building this? Is your
repository clean? After "make clean", do you get the same error?

cheers,
--renato

Yes, same error after "make clean all check-all".

This is a configure build (I usually run "make happiness" each
morning) on Ubuntu LTS 12.04 with gcc version 4.6.3 (Ubuntu/Linaro
4.6.3-1ubuntu5)
It was working fine three days ago.

Csaba

Weird, I’m not getting that on:

Ubuntu 12.10, x64 + ARM (gcc 4.7.2)
Ubuntu 12.04, ARM (gcc 4.6.3)

cheers,
–renato

The SystemZ disassembler was only recently added. To process major changes
to the source tree like the addition of a completely new component, it
seems to be necessary to explicitly re-run configure (or sometimes even
remove the build directory completely and start from scratch). I've seen
similar problems in the past (e.g. when the PowerPC assembler was added, or
when the SystemZ target itself was added).

For some reason, a simple "make" or "make clean" does not appear to detect
that it needs to re-run configure. Can you try doing this manually on your
build system?

Bye,
Ulrich

Yes! Like we did in the ARM buildbot.

Though, our problem was a compilation error, I'll not be surprised if a
fresh build directory fixes everything.

cheers,
--renato

Thanks, that fixed it.
I re-ran configure and then "make happiness" passed. A "make clean"
was not necessary.

Csaba