The angry `clang-ve-ninja` build bot

I had a couple of patches that could not build on the mentioned build bot.
Could anyone give me hints about how to reproduce these issues?

I tried to tag @simoll under the related patch, without much luck.
Hereby I’m officially requesting help from the rest of the community.

Any guidance on how to resolve these if I cannot reproduce them locally?

Link to the offended patch stack: https://reviews.llvm.org/D118987
Link to the stdout of the bot: https://lab.llvm.org/buildbot/#/builders/91/builds/3818

@gkistanova

The CMake invocation is:

cd "/scratch/buildbot/bothome/clang-ve-ninja/build/build_llvm" && cmake /scratch/buildbot/bothome/clang-ve-ninja/build/../llvm-project/llvm -G Ninja \
      -C /home/buildbot/tools-config.cmake \
      -DCMAKE_BUILD_TYPE=RelWithDebInfo \
      -DLLVM_BUILD_LLVM_DYLIB=Off \
      -DLLVM_LINK_LLVM_DYLIB=Off \
      -DCLANG_LINK_CLANG_DYLIB=Off \
      -DLLVM_TARGETS_TO_BUILD="X86;VE" \
      -DLLVM_ENABLE_PROJECTS="clang" \
      -DCMAKE_INSTALL_PREFIX=""/scratch/buildbot/bothome/clang-ve-ninja/build/install"" \
      -DLLVM_INSTALL_UTILS=On

That’s available here. I wasn’t able to find tools-config.cmake which you will need to reproduce this.

Your tests need REQUIRES: asserts; -debug-only only exists in asserts builds.

Thanks for the response. I’ll check it.

It seems like it worked! Thanks again.