"Unsupported Availability Guard" Warning

To recap, it _______.

Whoops, I forgot to fill in the blank. To recap, it allows you to guard a block of code to at least a certain OS version so that it won't emit "unguarded availability" warnings if you use APIs that are only available on that OS version.