Updated sphinx and dependencies on the sphinx doc publishing builder

Per LLDB team’s request I have added Furo sphinx theme to the publish-sphinx-docs builder.

This triggered versions update for sphinx and dependencies.
The current requirements are

sphinx==7.1.2
docutils==0.20.1
sphinx-markdown-tables==0.0.17
recommonmark==0.7.1
sphinx-automodapi==0.16.0
sphinx-bootstrap-theme==0.8.1
sphinxcontrib-applehelp==1.0.4
furo==2023.8.19

The builder is temporarily moved to the staging, but it is still publishing the docs.

Please check warnings related to your projects and fix them whenever possible, Currently there is quite a few in LLDB and Flang.

Please let me know if any dependency is missing on that bot.