Visual C patches - forgot to attach to last mail...

diff.txt (7.91 KB)

Hi,

There's no HAVE_RAND48 symbol provided by autoconf. You'll have to add the appropriate check to autoconf/configure.ac before we can take this patch.

Thanks,

-Brian

Hi,

There's no HAVE_RAND48 symbol provided by autoconf. You'll have to add the appropriate check to autoconf/configure.ac before we can take this patch.

Sorry I forgot to mention I didn't make any changes to the configure script. The problem is that I can't test these things since I'm not on a Unix platform, and I'm not even using the configure/make build process. Chris' suggestion when I first mentioned this problem was to zap these rand48 things so I wasn't so worried about it... Can we apply the patch and wait for someone (who presumably needs these) to volunteer to fix the configure script?

m.

Morten Ofstad wrote:

Hi,

There's no HAVE_RAND48 symbol provided by autoconf. You'll have to add the appropriate check to autoconf/configure.ac before we can take this patch.

I installed autoconf with cygwin now and I think I've managed to do this right now -- there are some strange problems with running the AutoRegen.sh script, so I had to do it manually... Here are the patches and the new test (which goes in autoconf/m4).

m.

diff.txt (4.51 KB)

rand48.m4 (376 Bytes)

Morten,

39 reconfigures later :slight_smile: .. this patch has been committed, but it doesn't look much like the original. I would have sent this patch back but the problem was in existing m4 macros. Please note that the AC_SINGLE_CXX_CHECK macro has changed to make it actually work. It is not *correct* to AC_DEFINE where the
first argument is not a literal. That means you have to provide a separate AC_DEFINE for each variable, not encapsulate them the way AC_SINGLE_CXX_CHECK used to do. I have also fixed the HAVE_ISNAN* and HAVE_ISINF* defines.

Reid

Morten Ofstad wrote: