VMKit: Problem compiling vmkit

Hi,

I'm trying to compile vmkit but am running into some problems. I followed the instructions at http://vmkit.llvm.org/get_started.html and checked out llvm and clang from svn, compiled them no problem and the same with classpath 0.97.2. I then checked out vmkit from svn and tried to build it. All these are located at /home/callum/vmkit/{llvm,classpath-0.97.2,vmkit}.

I used this to configure vmkit:

PRE=/home/callum/vmkit
./configure --with-llvmsrc="$PRE/llvm" \
--with-llvmobj="$PRE/llvm" \
--with-gnu-classpath-glibj="$PRE/classpath-0.97.2/lib/glibj.zip" \
--with-gnu-classpath-libs="$PRE/classpath-0.97.2/lib" \
--with-mmtk-plan=org.mmtk.plan.marksweep.MS

but when I try make this happens:

callum@callum-vm:~/vmkit/vmkit$ make ENABLE_OPTIMIZED=1
llvm[0]: Constructing LLVMBuild project information.
make[1]: Entering directory `/home/callum/vmkit/vmkit/lib/vmkit/StaticGCPass'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/callum/vmkit/vmkit/lib/vmkit/StaticGCPass'
make[1]: Entering directory `/home/callum/vmkit/vmkit/lib/vmkit/StaticGCPrinter'
llvm[1]: Compiling VmkitGCPrinter.cpp for Release+Asserts build (PIC)
VmkitGCPrinter.cpp: In member function ‘virtual void {anonymous}::VmkitAOTGCMetadataPrinter::finishAssembly(llvm::AsmPrinter&)’:
VmkitGCPrinter.cpp:292:63: error: no matching function for call to ‘llvm::DataLayout::getPointerSize() const’
VmkitGCPrinter.cpp:292:63: note: candidate is:
/home/callum/vmkit/llvm/include/llvm/DataLayout.h:250:12: note: unsigned int llvm::DataLayout::getPointerSize(unsigned int) const
/home/callum/vmkit/llvm/include/llvm/DataLayout.h:250:12: note: candidate expects 1 argument, 0 provided
/bin/rm: cannot remove `/home/callum/vmkit/vmkit/lib/vmkit/StaticGCPrinter/Release+Asserts/VmkitGCPrinter.d.tmp': No such file or directory
make[1]: *** [/home/callum/vmkit/vmkit/lib/vmkit/StaticGCPrinter/Release+Asserts/VmkitGCPrinter.o] Error 1
make[1]: Leaving directory `/home/callum/vmkit/vmkit/lib/vmkit/StaticGCPrinter'
make: *** [all] Error 1

Am I using the wrong versions of llvm/vmkit together? Or the configure options wrong? Is there a release of vmkit that works with llvm 3.1 (I can see up to llvm 3.0 on the website http://vmkit.llvm.org/releases/index.html) as the bindings library I'm using depends of llvm 3.1.

Thanks in advance,
Callum

Hi Callum,

You followed the instructions right. I just udpated vmkit to the new LLVM API and everything should compile now.

Cheers,
Nicolas