VS2019 + LLVM Toolchain Plugin Support

Hi [Zachary],

I recently cleaned up my VS-installs, i.e. removed both VS17 and VS19 (which were installed side-by-side up till then] and ran into an installation problem. Previously, with both VS17 and VS19 installed, the plugin worked ‘just fine’ both in VS17 and VS19. Now with only VS19 installed, the plugin does not register in VS19 [resulting in tool-chain not installed error]. This behavior I also observed with the old style integration (Clang-7) with VS15 and VS17 (that’s how we got the plugin published, when I reported that problem). VS19 pulls in everything installed in VS19, that’s how the old style integration kept working as well.

I have posted the install log to pastebin [0], in which you can see that VS19 is actually not “supported” according to it’s settings/parameters. I’ve tried to fix these vc17’s and changed them to vc19’s, throughout, but that doesn’t do the trick [locations of files seem to be different as well]. In other words I cannot fix it as I don’t understand well enough what should be fixed and to what.

Would be great to get it working again.

Have a good day,

degski