vscode-clangd; feature request

clangd developers,

sorry, if this is not the right way to communicate my request.

Please suggest to add Objective-C and Objective-C++ to the language services to activate the vscode extension on. To achieve this package.json should read (at least):


        "activationEvents": [
                "onLanguage:c",
                "onLanguage:cpp",
                "onLanguage:objective-c",
                "onLanguage:objective-cpp"
        ],

Thanks in advance.

Best regards,

Andreas Ostermeyer

+via clangd-dev

Thanks for raising this, sent https://reviews.llvm.org/D57813 for review to fix this.

Ilya,

Thanks for the info and involving me. This (D57813) does the trick for me and is what I’d suggested.

Regards,
Andreas Ostermeyer

I literally transcribed your suggestion into code, many thanks for showing how to fix this!
We should soon land it and get the VSCode extension updated.

Andreas, we have made a new release of vscode-clangd extension to pick up the fix, please upgrade your extension. Thanks.

Done. The plugin version now reads 0.0.11 and works like expected. Thanks a lot.
May be the Marketplace Readme could now mention, too, that Objective-C language IDE features are also provided.
Regards to all. Awesome job.