Win32 build broken

I’ve updated a couple times over the few days, but the win32 build is broken in a number of places.

One is some missing .inc files. Perhaps the cmake build files need updating?:

54>D:\Clang\llvmref\tools\clang\include\clang/AST/Comment.h(89): fatal error C1083: Cannot open include file: ‘clang/AST/CommentNodes.inc’: No such file or directory

62>D:\Clang\llvmref\tools\clang\include\clang/Sema/AttributeList.h(170): fatal error C1083: Cannot open include file: ‘clang/Sema/AttrParsedAttrList.inc’: No such file or directory

And many missing symbols, i.e.:

48>D:\Clang\llvmref\tools\clang\lib\Basic\IdentifierTable.cpp(44): error C2065: ‘IsImport’ : undeclared identifier

48>D:\Clang\llvmref\tools\clang\lib\Basic\Diagnostic.cpp(368): error C2065: ‘FixItHints’ : undeclared identifier

John,

I have not seen any issues in clang with MS compiler now.
Lemme know,

  - the revision
  - the version of cmake
  - configuration, x64, Win32, Debug, Release, ...

FYI, He is building with Release.
http://bb.pgr.jp/builders/cmake-clang-i686-msvc10

...Takumi

Thanks, Nakamura-san. I was on cmake 2.8.5, so some combination of updating to 2.8.8, deleting the CMakeCache.txt file, and regenerating the project files with "cmake -G “Visual Studio 10” -DCLANG_BUILD_EXAMPLES=ON " fixed it. This should always be the proceedure when facing build problems on Windows after being away for a long time.

-John

John,

I am happy for you to resolve your issue.

I am unhappy whenever updated source tree would not be built fine, though. :stuck_out_tongue:
Lemme know if you knew build glitch among revisions on cmake.

...Takumi