[www] Is the website being updated from the monorepo?

Hi,

In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.

Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?

Thanks,
STL

[0] https://reviews.llvm.org/D69363
[1] https://github.com/llvm/llvm-project/commit/2e4f1e112dfee1d16c138d42f2bc7ee639f9ae05

It should be but it seems that Sphinx bots for both LLVM and Clang
docs are not working for some reason despite being green on the
buildbot console. I've noticed this earlier as well.

Hi,

In D69363 [0] committed as 2e4f1e1 [1], I changed many URLs in Clang's HTML files to be HTTPS. However, I don't see these changes on https://clang.llvm.org , two days later.

Is Clang's website being automatically updated from the monorepo, or does it still need to be migrated, or is manual action necessary?

We are aware and working on getting this fixed.

-Tom

[STL]

Is Clang's website being automatically updated from the monorepo,
or does it still need to be migrated, or is manual action necessary?

[Kristina Brooks]

It should be but it seems that Sphinx bots for both LLVM and Clang
docs are not working for some reason despite being green on the
buildbot console. I've noticed this earlier as well.

That's useful info, thanks. I didn't even know what to look for.

[Tom Stellard]

We are aware and working on getting this fixed.

Great, thanks!

STL

Hi Tom / Mike,

I'm curious about the status of this. I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.

I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.

Thanks,
Duncan

Hi Tom / Mike,

I'm curious about the status of this. I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.

I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.

It was working and then it stopped again. We are working on getting it
fixed.

-Tom

Hi Tom / Mike,

I'm curious about the status of this. I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren't reflected at https://clang.llvm.org/docs/AttributeReference.html.

I'm not sure if you're still working on it, if we got it working and it regressed, or if maybe I'm just not patient enough.

It was working and then it stopped again. We are working on getting it
fixed.

Thanks Tom!

Hi Tom / Mike,

I’m curious about the status of this. I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren’t reflected at https://clang.llvm.org/docs/AttributeReference.html.

I’m not sure if you’re still working on it, if we got it working and it regressed, or if maybe I’m just not patient enough.

It was working and then it stopped again. We are working on getting it
fixed.

-Tom

https://clang.llvm.org/docs/AttributeReference.html is currently empty, but I’ve verified that clang-tblgen -gen-attr-docs works.

  • Michael Spencer

Hi Tom / Mike,

I’m curious about the status of this. I noticed that the changes from https://reviews.llvm.org/D69991#change-QasK3GY5Z3ZX (landed on Monday as d4e1ba3fa9dfec2613bdcc7db0b58dea490c56b1) aren’t reflected at https://clang.llvm.org/docs/AttributeReference.html.

I’m not sure if you’re still working on it, if we got it working and it regressed, or if maybe I’m just not patient enough.

It was working and then it stopped again. We are working on getting it
fixed.

-Tom

https://clang.llvm.org/docs/AttributeReference.html is currently empty, but I’ve verified that clang-tblgen -gen-attr-docs works.

  • Michael Spencer

Still empty.

  • Michael Spencer

As of right now (literally 22:16PST on 2020-01-07) the page at https://clang.llvm.org/docs/AttributeReference.html is alive an well. I think I have figured out the issues with the old update scripts and I’m hoping this page will continue updating without further issue. If something breaks just ping me and I’ll try my best to get things fixed as quickly as possible. Also, just an FYI, I am working with the fine folks over at Access Softek on a real long term solution to this problem which will involve bots doing CI work for docs generation and other bots doing CD work to keep the website continuously up to date.

Thanks,
Mike

As of right now (literally 22:16PST on 2020-01-07) the page at https://clang.llvm.org/docs/AttributeReference.html is alive an well. I think I have figured out the issues with the old update scripts and I’m hoping this page will continue updating without further issue. If something breaks just ping me and I’ll try my best to get things fixed as quickly as possible. Also, just an FYI, I am working with the fine folks over at Access Softek on a real long term solution to this problem which will involve bots doing CI work for docs generation and other bots doing CD work to keep the website continuously up to date.

Thanks,
Mike

Looks like it works. Thanks!

  • Michael Spencer