Xcode toolchain compatibility

The generated Xcode toolchain is (now?) incompatible with Xcode 8 on
Sierra. A few tweaks are necessary for Xcode 8:

1- rename the plist to ToolchainInfo.plist
2- use the default Xcode toolchain as a more "modern" template
3- change compatibility id to 2 instead of 1

There may be some other necessary tweaks, but at least these keep
Xcode happy.

Just FYI for anyone struggling with this. I will update this bug
https://llvm.org/bugs/show_bug.cgi?id=29070
if necessary.

P.