apt-get problems

Hi,

Not sure if this is related to the domain change last week, but I am having trouble using apt-get to install the packages.
I am getting a not found and a problem with the certificate

Steps:

echo “deb http://apt.llvm.org/xenial/ llvm-toolchain-xenial-3.9 main”> /etc/apt/sources.list.d/llvm.list
wget -O - http://apt.llvm.org/llvm-snapshot.gpg.key|sudo apt-key add -

Output:

root@RIO:/mnt/e/_Working/BEM# apt-get update
0% [Working]
Ign:1 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9 InRelease
Ign:2 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9 Release
Ign:3 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main amd64 Packages
Ign:4 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main all Packages
Ign:5 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en_US
Ign:6 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en
Ign:3 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main amd64 Packages
Ign:4 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main all Packages
Ign:5 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en_US
Ign:6 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en
Ign:3 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main amd64 Packages
Ign:4 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main all Packages
Ign:5 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en_US
Ign:6 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en
Ign:3 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main amd64 Packages
Ign:4 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main all Packages
Ign:5 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en_US
Ign:6 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en
Ign:3 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main amd64 Packages
Ign:4 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main all Packages
Ign:5 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en_US
Ign:6 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en
Err:3 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main amd64 Packages
404 Not Found
Ign:4 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main all Packages
Ign:5 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en_US
Ign:6 http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9/main Translation-en
Hit:7 http://archive.ubuntu.com/ubuntu xenial InRelease
Hit:8 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:9 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial InRelease
Hit:10 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:11 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu xenial InRelease
Hit:12 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
Reading package lists… Done
W: The repository ‘http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9 Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://apt.llvm.org/xenial/dists/llvm-toolchain-xenial-3.9/main/binary-amd64/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Mac

Hi,

I am still getting a 404 when trying to use the llvm.org packages. Should I be emailing another list?

Mac

Hi,

I am still getting a 404 when trying to use the llvm.org packages. Should I be emailing another list?

  • Sylvestre Ledru

Tried today and it seems like the repo is still not working:

W: The repository ‘http://apt.llvm.org/xenial llvm-toolchain-xenial-3.9 Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://apt.llvm.org/xenial/dists/llvm-toolchain-xenial-3.9/main/binary-amd64/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Not sure what happened. I just retrigered a new build. Should be fixed today or tomorrow.

Sorry about that
Sylvestre

This is now fixed.

By the way, I am working on the branching of 4.0 and introducing 5.0
packages :slight_smile:

S