[Bug 20658] New: LLDB lies about --disable-aslr and leaves ASLR enabled

Bug ID 20658
Summary LLDB lies about --disable-aslr and leaves ASLR enabled
Product lldb
Version unspecified
Hardware PC
OS All
Status NEW
Severity normal
Priority P
Component All Bugs
Assignee lldb-dev@cs.uiuc.edu
Reporter chandlerc@gmail.com
CC david.majnemer@gmail.com, tfiala@google.com
Classification Unclassified

Todd Fiala changed bug 20658

What Removed Added
Assignee lldb-dev@cs.uiuc.edu tfiala@google.com
OS All Linux

Comment # 1 on bug 20658 from Todd Fiala

Implementation note:

This link shows a response that indicates how to disable via shell execution:
[https://stackoverflow.com/questions/5194666/disable-randomization-of-memory-addresses](https://stackoverflow.com/questions/5194666/disable-randomization-of-memory-addresses)

So a shell wrapping the inferior with proper flags set is one way to go about
it for per-process-level ASLR setting (rather than the whole-system kernel
flag).

I'll look at getting the disable aslr support in after my next task wraps up.

As for making it the default, great thing to discuss on lldb-dev.  At the very
least I'm good with making it the default on Linux.  If everyone else agrees,
we can get it working as a global default.

-Todd