How to enable c++11 in a llvm project?

Hi,

I’m using the latest LLVM (r168491) built by GCC 4.7.2 (Gentoo masked version). The clang++ runs as expected when I compile a hello program with c++11 enabled.

I created a project (copied from sample/) where there are some C++ source files with c++11 features. I configured my project using the following command:
$ CXXFLAGS="-std=c++11" …/configure --enable-cxx11
However, I found that the clang++ did not build my project with the “-std=c++” option[1].

Could anyone kindly show me how to enable C++11 in a LLVM project, please?

Thank you.
Miangliang.

[1] I get the detailed options building my project using ‘make VERBOSE=1’

Hi,

I use the following line to configure, which can enable the c++11 in the project building. However, I don’t think it’s an elegant way to do the trick.
$ CXX=“clang++ -std=c++11” …/configure

I don’t know why “-enable-cxx11” doesn’t work as expected when I configure the project.

Regards.

I’ve added the missing magic to Makefile.llvm.rules in r168685.

Hi Craig,

It works! Thank you very much.

Mingliang