LLDBWrapPython.cpp missing message

Hi folks

I've been having trying to get the lldb python tests working. My setup is linux Fedora Core 20 64 bit. I tried to follow some of Todd Fiala's troubleshooting tips earlier using the autoconf/make route, and I got bogged down with some faults (see [lldb-dev] Problems running the lldb tests on Fedora Core 20 - 64bit (email originally titled "Add kalimba as a platform.").

So I thought I'd try the cmake/ninja route and see if things are different. I invoked cmake as follows:


However then I see the following diagnostic from cmake:

-- Configuring done
CMake Warning (dev) at tools/lldb/source/CMakeLists.txt:297 (add_dependencies):
   Policy CMP0046 is not set: Error on non-existent dependency in
   add_dependencies. Run "cmake --help-policy CMP0046" for policy details.
   Use the cmake_policy command to set the policy and suppress this warning.

   The dependency target
   "/home/mg11/src/p4play/build/tools/lldb/scripts/LLDBWrapPython.cpp" of
   target "liblldb" does not exist.
This warning is for project developers. Use -Wno-dev to suppress it.

-- Generating done
-- Build files have been written to: /home/mg11/src/p4play/build

So should I be alarmed by

   The dependency target
   "/home/mg11/src/p4play/build/tools/lldb/scripts/LLDBWrapPython.cpp" of
   target "liblldb" does not exist.


What does this mean?


Member of the CSR plc group of companies. CSR plc registered in England and Wales, registered number 4187346, registered office Churchill House, Cambridge Business Park, Cowley Road, Cambridge, CB4 0WZ, United Kingdom
More information can be found at www.csr.com. Keep up to date with CSR on our technical blog, www.csr.com/blog, CSR people blog, www.csr.com/people, YouTube, www.youtube.com/user/CSRplc, Facebook, www.facebook.com/pages/CSR/191038434253534, or follow us on Twitter at www.twitter.com/CSR_plc.
New for 2014, you can now access the wide range of products powered by aptX at www.aptx.com.

Hmm, that file I believe is the wrapper generated by the swig bindings-generator library.

I don’t think that is an issue and is expected (?), although I don’t remember seeing it. Typically I run with -Wno-dev unless I’m modifying the cmake files. This warning may have creeped in more recently, but I don’t think it represents an error. There may be a way to tell cmake that this file is generated and won’t exist yet. (That might be the issue - cmake may not be told that it is generated by the swig binding generator step, which itself is hidden behind a script invocation I think). We can probably clean up that warning with a little work, but for now you can either ignore it or add the -Wno-dev to block it from sight.


LLDBWrapPython.cpp is a generated file. It’s normal that the file doesn’t exist if you’re doing a clean build. But it’s unusual that it’s calling “/home/mg11/src/p4play/build/tools/lldb/scripts/LLDBWrapPython.cpp” a target, and not a file. I’m also not sure why I’ve never seen this message before, maybe it’s platform specific? Still, my first thought is that there’s a bug in the CMake, because that shouldn’t be a target, it should be a file, which is generated when building some other target. Either way, I would suggest just trying to debug the CMake a little. Find the target that supposedly generates that file, then find the place where add_dependency is called. Make sure that the dependency is specifying the target and not the file.

Ok, thanks.

Zachary Turner wrote: