Missing cl::parser<unsigned long> specialization?

Hi all,

I’m using a cl::opt<uint64_t>. On Mac OS X, uint64_t is unsigned long long, and so by default the option uses the parser specialization. However, on Linux, it’s unsigned long, and there is no specialization for it. Because of it, the option has the default parser that expects a value from a predefined list, which is impractical for 64-bit numbers.

Is that on purpose?