New contributor, `make test` not doing anything

I came to the recent LLVM/Clang hackathon and made a new checker for clang-tidy. I’m working on wrapping up and submitting my patch, and I can’t seem to run the tests.

  • First, I followed the instructions at I ran make test in my build directory, and also tried running make in the test subdirectory. They both exited in under a second with no output.

  • Then, I tried doing the same thing in the tools/clang/tools/extra subdirectory of my build directory, where clang-tidy lives. Same result.

  • Finally, I found This explains how to create tests but not how to run them. I made a relatively wonky command line that seems to run my test successfully (along the lines of PATH=$PATH:$BUILD_DIR/bin ./ ../../test/clang-tidy/misc-my-check.cpp misc-my-check /tmp/foo.tmp), but it doesn’t feel right.

What should I be doing instead?

You’ll probably have better chance on the cfe-dev mailing-list
(LLVM-dev to BCC).


I haven’t come across ‘make test’ before and this target doesn’t exist when building with ninja. I’m guessing that make is checking whether ‘test’ is up to date, finding the ‘./test’ directory, and concluding there’s nothing to do.

I think you’re looking for ‘make check-all’. There’s various check-* targets for particular subsets of the tests but I don’t know the one for clang-tidy’s tests.