[RFC] Inconsistent naming convention of docs and test folders


I recently added a new check with “add_new_check.py” and it created 2 files:


So one folder uses checks and another uses checkers. Would it make sense to harmonize the naming convention?

I believe it might be easier to change “checkers” to “checks”, since it’s just a file rename. Changing “checks” to “checkers” will also require changes to the source code, since it changes the URL of the docs for each check, which is part of the API documentation of the class implementing each check.

This seems like a non issue in my mind and not worth chasing.