Ubuntu packages with LLVM 14, then 15 suddenly looking for libpolly.a

Starting a few days ago, CI with LLVM 14 on Ubuntu started failing for my compiler. The error was

ninja: error: '/usr/lib/llvm-14/lib/libPolly.a', needed by 'c3c', 
missing and no known rule to make it

Now the LLVM 15 packages are failing as well.with the same error. LLVM 13 and 16 are still working. These are all retrieved from https://apt.llvm.org/focal

By pulling in libpolly I got LLVM 15 to work, but no such luck with LLVM 14. It would then not be able to find Clang