Build-bot host compiler upgrades and C++11!

Greetings, I’m reaching out as you guys are a big subproject but I don’t know much about build infrastructure or bots over there…

As you may have heard on the LLVM list, we’re planning to switch to use C++11 now that 3.4 is out. The first step is establishing a new baseline of compiler versions that are supported[1]:

MSVC 2012
GCC 4.7
Clang 3.1

If you are helping to keep build bot infrastructure running and up-to-date, please check the host compiler versions and reply here if you’re going to have trouble upgrading. My rough plan based on chatting with some folks is to submit checks to cmake and configure on Monday to produce an error on older toolchains without some flag to force old toolchain support.

So reply to this thread if you need more time, or if all your bots are ready-to-go! Thanks a bunch!
-Chandler

[1]: Most of these compilers were available in the middle (June) of 2012, and based on the planned 3.5 release time frame of the middle of 2014, that will mean a roughly two year spread of compiler releases. MSVC 2012 was later, but the community seems comfortable with requiring the upgrade. Also, these versions include very significant improvements that make adopting C++11 features much more viable. This was discussed at some length back on the LLVM list, but I’m happy to answer any questions about the plan, why, when, and what the impact should be!

The FreeBSD LLDB buildbots are ready to go. (The amd64 buildbot has
been failing due to LLVM test failures since mid December, but LLDB
itself tests fine. FreeBSD/i386 LLDB doesn't yet work.)
http://llvm-amd64.freebsd.your.org:8010/builders/lldb-amd64-freebsd
http://llvm-amd64.freebsd.your.org:8010/builders/lldb-i386-freebsd

The Debian Clang buildbot claims to use a recent ToT clang, so it
should be fine.
http://lab.llvm.org:8011/builders/lldb-x86_64-debian-clang

The other Linux buildbot and the Darwin buildbot seem to be broken at
the moment.
http://lab.llvm.org:8011/builders/lldb-x86_64-linux
http://lab.llvm.org:8011/builders/lldb-x86_64-darwin11

In any case, LLDB has already required C++11 for some time.

-Ed