make check fails on mingw

Hi,

I’m trying to test the llvm tools as described in ‘http://llvm.cs.uiuc.edu/docs/TestingGuide.html’.

However, when running the command: 'make check VERBOSE=1 2>&1' I get this error:

I’m trying to test the llvm tools as described in ‘http://llvm.cs.uiuc.edu/docs/TestingGuide.html’.

The problem here is that your PATH envvar has spaces in it. There are many thing in LLVM that won't work with that, please try pruning your PATH and trying again.

Thanks,

-Chris

However, when running the command: 'make check VERBOSE=1 2>&1' I get this error:
-------------------
if test -d "/C/projects/build/MinGW/llvm-2-1/test" ; then \
if test -f "/C/projects/build/MinGW/llvm-2-1/test/Makefile" ; then \
  echo llvm[0]: Running test suite ; \
  make -C /C/projects/build/MinGW/llvm-2-1/test check-local \
    TESTSUITE= ; \
else \
  echo llvm[0]: No Makefile in test directory ; \
fi ; \
else \
echo llvm[0]: No test directory ; \
fi
llvm[0]: Running test suite
make[1]: Entering directory `/C/projects/build/MinGW/llvm-2-1/test'
PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:/C/projects/src/llvm-2/llvm/test/Scripts:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip \
true runtest
/bin/sh.exe: Files/cvsnt:/c/Program: No such file or directory
make[1]: *** [check-local] Error 127
make[1]: Leaving directory `/C/projects/build/MinGW/llvm-2-1/test'
make: *** [check] Error 2
-------------------

Obviously, the shell tries to locate 'runtest'. runtest is located in:
-------------------
$ which runtest
/usr/local/bin/runtest
-------------------
which is the path and
-------------------
$ runtest --version | tee -a my_runtest.log
WARNING: Couldn't find the global config file.
Expect version is 5.21
Tcl version is 8.0
Framework version is 1.4.4
-------------------

Looking at the 'objdir/test/site.exp' generated file we find:
-------------------
## these variables are automatically generated by make ##
# Do not edit here. If you wish to override these values
# edit the last section
set target_triplet i686-pc-mingw32
set prcontext " /C/projects/src/llvm-2/llvm/test/Scripts/prcontext.tcl"
set srcdir /C/projects/src/llvm-2/llvm/test
set objdir /C/projects/build/MinGW/llvm-2-1/test
set llvmgcc "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip llvm-gcc"
set llvmgxx "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip llvm-gcc"
## All variables above are generated by configure. Do Not Edit ##
-------------------

If we look close at the path variables in the site.exp, we have that the last folder '/c/Program Files/7-Zip llvm-gcc' isn't correct. llvm-gcc shouldn't be in there, because I haven't such folder.

Any suggestions?

=============================================================
Henrik Bach
LLVM Open Source Developer

e-mail: henrik_bach_llvm at hotmail.com

'Nothing is impossible; The impossible just takes longer time :)' - Inventor of a new energy saver light bulp from Denmark.

No software patents - Thank you Poland: http://www.nosoftwarepatents.com/en/m/intro/app0411.html
Got Freedom?
Software Freedom Day - 28th of August
http://www.softwarefreedomday.org/

_________________________________________________________________
Få alle de nye og sjove ikoner med MSN Messenger http://messenger.msn.dk/

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

Either that, or use something like the famous "progra~1" instead of
"program files".

Anyway to clean the test system or can I delete site.exp safely?

Henrik.

Now, I've no spaces in my path:

Anyway to clean the test system or can I delete site.exp safely?

Run "make clean" in the test directory. I think there is a small bug becuase site.exp is not deleted when you run that, but you can manually delete it.

-Tanya

"PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread llvm-gcc"
set llvmgxx "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread llvm-gcc"
## All variables above are generated by configure. Do Not Edit ##
------------------

llvm-gcc is still present in the path var's which I don't understand.

These aren't setting path variables. These are commands. With bourne shell, it's legal to say:

ENVVAR=foo ./command

instead of:
export ENVVAR=foo
./command

That's all it is doing.

-Chris

----Original Message Follows----
From: Chris Lattner <sabre@nondot.org>
Reply-To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
Subject: Re: [LLVMdev] make check fails on mingw
Date: Fri, 7 Jan 2005 12:32:55 -0600 (CST)

I’m trying to test the llvm tools as described in ‘http://llvm.cs.uiuc.edu/docs/TestingGuide.html’.

The problem here is that your PATH envvar has spaces in it. There are many thing in LLVM that won't work with that, please try pruning your PATH and trying again.

Thanks,

-Chris

However, when running the command: 'make check VERBOSE=1 2>&1' I get this error:
-------------------
if test -d "/C/projects/build/MinGW/llvm-2-1/test" ; then \
if test -f "/C/projects/build/MinGW/llvm-2-1/test/Makefile" ; then \
  echo llvm[0]: Running test suite ; \
  make -C /C/projects/build/MinGW/llvm-2-1/test check-local \
    TESTSUITE= ; \
else \
  echo llvm[0]: No Makefile in test directory ; \
fi ; \
else \
echo llvm[0]: No test directory ; \
fi
llvm[0]: Running test suite
make[1]: Entering directory `/C/projects/build/MinGW/llvm-2-1/test'
PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:/C/projects/src/llvm-2/llvm/test/Scripts:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip \
true runtest
/bin/sh.exe: Files/cvsnt:/c/Program: No such file or directory
make[1]: *** [check-local] Error 127
make[1]: Leaving directory `/C/projects/build/MinGW/llvm-2-1/test'
make: *** [check] Error 2
-------------------

Obviously, the shell tries to locate 'runtest'. runtest is located in:
-------------------
$ which runtest
/usr/local/bin/runtest
-------------------
which is the path and
-------------------
$ runtest --version | tee -a my_runtest.log
WARNING: Couldn't find the global config file.
Expect version is 5.21
Tcl version is 8.0
Framework version is 1.4.4
-------------------

Looking at the 'objdir/test/site.exp' generated file we find:
-------------------
## these variables are automatically generated by make ##
# Do not edit here. If you wish to override these values
# edit the last section
set target_triplet i686-pc-mingw32
set prcontext " /C/projects/src/llvm-2/llvm/test/Scripts/prcontext.tcl"
set srcdir /C/projects/src/llvm-2/llvm/test
set objdir /C/projects/build/MinGW/llvm-2-1/test
set llvmgcc "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip llvm-gcc"
set llvmgxx "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip llvm-gcc"
## All variables above are generated by configure. Do Not Edit ##
-------------------

If we look close at the path variables in the site.exp, we have that the last folder '/c/Program Files/7-Zip llvm-gcc' isn't correct. llvm-gcc shouldn't be in there, because I haven't such folder.

Any suggestions?

=============================================================
Henrik Bach
LLVM Open Source Developer

e-mail: henrik_bach_llvm at hotmail.com

'Nothing is impossible; The impossible just takes longer time :)' - Inventor of a new energy saver light bulp from Denmark.

No software patents - Thank you Poland: http://www.nosoftwarepatents.com/en/m/intro/app0411.html
Got Freedom?
Software Freedom Day - 28th of August
http://www.softwarefreedomday.org/

_________________________________________________________________
Få alle de nye og sjove ikoner med MSN Messenger http://messenger.msn.dk/

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

--
http://nondot.org/sabre/
http://llvm.cs.uiuc.edu/
_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

_________________________________________________________________
Log på MSN Messenger direkte fra nettet http://webmessenger.msn.com/

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

You're right. And no errors or results where generated:

You're right. And no errors or results where generated:

PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:/C/projects/src/llvm-2/llvm/test/Scripts:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread \
true runtest
make[1]: Leaving directory `/C/projects/build/MinGW/llvm-2-1/test'

Shouldn't a bunch of tests appear?

The "true runtest" line indicates that configure was not able to find dejagnu.

-Chris

----Original Message Follows----
From: Chris Lattner <sabre@nondot.org>
Reply-To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
Subject: Re: [LLVMdev] make check fails on mingw
Date: Fri, 7 Jan 2005 13:17:09 -0600 (CST)

"PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread llvm-gcc"
set llvmgxx "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread llvm-gcc"
## All variables above are generated by configure. Do Not Edit ##
------------------

llvm-gcc is still present in the path var's which I don't understand.

These aren't setting path variables. These are commands. With bourne shell, it's legal to say:

ENVVAR=foo ./command

instead of:
export ENVVAR=foo
./command

That's all it is doing.

-Chris

----Original Message Follows----
From: Chris Lattner <sabre@nondot.org>
Reply-To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
Subject: Re: [LLVMdev] make check fails on mingw
Date: Fri, 7 Jan 2005 12:32:55 -0600 (CST)

I’m trying to test the llvm tools as described in ‘http://llvm.cs.uiuc.edu/docs/TestingGuide.html’.

The problem here is that your PATH envvar has spaces in it. There are many thing in LLVM that won't work with that, please try pruning your PATH and trying again.

Thanks,

-Chris

However, when running the command: 'make check VERBOSE=1 2>&1' I get this error:
-------------------
if test -d "/C/projects/build/MinGW/llvm-2-1/test" ; then \
if test -f "/C/projects/build/MinGW/llvm-2-1/test/Makefile" ; then \
  echo llvm[0]: Running test suite ; \
  make -C /C/projects/build/MinGW/llvm-2-1/test check-local \
    TESTSUITE= ; \
else \
  echo llvm[0]: No Makefile in test directory ; \
fi ; \
else \
echo llvm[0]: No test directory ; \
fi
llvm[0]: Running test suite
make[1]: Entering directory `/C/projects/build/MinGW/llvm-2-1/test'
PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:/C/projects/src/llvm-2/llvm/test/Scripts:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip \
true runtest
/bin/sh.exe: Files/cvsnt:/c/Program: No such file or directory
make[1]: *** [check-local] Error 127
make[1]: Leaving directory `/C/projects/build/MinGW/llvm-2-1/test'
make: *** [check] Error 2
-------------------

Obviously, the shell tries to locate 'runtest'. runtest is located in:
-------------------
$ which runtest
/usr/local/bin/runtest
-------------------
which is the path and
-------------------
$ runtest --version | tee -a my_runtest.log
WARNING: Couldn't find the global config file.
Expect version is 5.21
Tcl version is 8.0
Framework version is 1.4.4
-------------------

Looking at the 'objdir/test/site.exp' generated file we find:
-------------------
## these variables are automatically generated by make ##
# Do not edit here. If you wish to override these values
# edit the last section
set target_triplet i686-pc-mingw32
set prcontext " /C/projects/src/llvm-2/llvm/test/Scripts/prcontext.tcl"
set srcdir /C/projects/src/llvm-2/llvm/test
set objdir /C/projects/build/MinGW/llvm-2-1/test
set llvmgcc "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip llvm-gcc"
set llvmgxx "PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/c/projects/src/CMHTREE/PLT/DOS.PLT:/c/WINNT/system32:/c/WINNT:/c/WINNT/System32/Wbem:/c/Program Files/cvsnt:/c/Program Files/7-Zip llvm-gcc"
## All variables above are generated by configure. Do Not Edit ##
-------------------

If we look close at the path variables in the site.exp, we have that the last folder '/c/Program Files/7-Zip llvm-gcc' isn't correct. llvm-gcc shouldn't be in there, because I haven't such folder.

Any suggestions?

=============================================================
Henrik Bach
LLVM Open Source Developer

e-mail: henrik_bach_llvm at hotmail.com

'Nothing is impossible; The impossible just takes longer time :)' - Inventor of a new energy saver light bulp from Denmark.

No software patents - Thank you Poland: http://www.nosoftwarepatents.com/en/m/intro/app0411.html
Got Freedom?
Software Freedom Day - 28th of August
http://www.softwarefreedomday.org/

_________________________________________________________________
Få alle de nye og sjove ikoner med MSN Messenger http://messenger.msn.dk/

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

--
http://nondot.org/sabre/
http://llvm.cs.uiuc.edu/
_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

_________________________________________________________________
Log på MSN Messenger direkte fra nettet http://webmessenger.msn.com/

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

--
http://nondot.org/sabre/
http://llvm.cs.uiuc.edu/
_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

_________________________________________________________________
Del din verden med MSN Spaces http://spaces.msn.com

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris

I'm not sure if dejagnu is installed correctly. Is there any way to call it on the command line?

I get this:

echo llvm[0]: No test directory ; \
fi
llvm[0]: Running test suite
make[1]: Entering directory `/C/projects/build/MinGW/llvm-2-1/test'
Making a new site.exp file...
PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:/C/projects/src/llvm-2/llvm/test/Scripts:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread \
true runtest
make[1]: Leaving directory `/C/projects/build/MinGW/llvm-2-1/test'
--------------------

Shouldn't a bunch of tests appear?

Do you have runtest (Dejagnu) on your system? It appears configure is not finding it.

-Tanya

I'm not sure if dejagnu is installed correctly. Is there any way to call it on the command line?

I get this:
-------------------
$ runtest --version | tee -a my_runtest.log
WARNING: Couldn't find the global config file.
Expect version is 5.21
Tcl version is 8.0
Framework version is 1.4.4
-------------------

It looks like dejagnu is installed and runs fine. You can also execute that command ('runtest') in the llvm test directory and it should run the Feature/Regression tests. You should expect to see a couple of warnings, thats normal.

-Tanya

Well, doing a runtest in the test folder gave me these results:

Yeah, it looks like dejagnu is fine, but configure is not finding it. Can you send in your 'configure' output? Was runtest in your path when you ran configure?

-Chris

Well, doing a runtest in the test folder gave me these results:
-----------------
WARNING: Couldn't find the global config file. WARNING: No tool specified Test Run By llvm on Fri Jan 7 20:55:24 2005
Native configuration is i686-pc-mingw32

    === tests ===

ERROR: (DejaGnu) proc "exp_debug" does not exist. The error code is NONE The info on the error is: can't rename to "exp_tcl_continue": command already exists while executing "rename continue exp_tcl_continue"
    === Summary ===

You are running a pretty old version of expect (5.21 was released in 1996). I would upgrade it to start. I'm not sure if that will fix your problem though as I am not an expect expert :slight_smile:

Did you follow the instructions to test if Dejagnu was installed correctly?
http://www.gnu.org/software/dejagnu/manual/x199.html

If you are still having problems after getting the latest expect and following the instructions from the dejagnu manual, then I would post to their mailing list.

What is the global config file?

The warning about a global config file is normal and you should ignore it.

-Tanya

In which folder does proc "exp_debug" exist, because I've downloaded (not build and installed this version) the latest version of expect (5.42), but cannot find it?

Henrik.

----Original Message Follows----

In which folder does proc "exp_debug" exist, because I've downloaded (not build and installed this version) the latest version of expect (5.42), but cannot find it?

I have no clue. Just install it.

-Tanya

I think I've found the reason why dejagnu complains about proc "exp_debug":

* Probably work, but not tested:
  debug

Bach to the drawing board :frowning:

Henrik.

----Original Message Follows----

I found that it was runtest.exp which referenced to the internal exp_debug function. For testing purposes I disabled the reference and ran a new:

make check VERBOSE=1

which gave me this:

I found that it was runtest.exp which referenced to the internal exp_debug function. For testing purposes I disabled the reference and ran a new:

Hi Henrik,

Unfortunately, none of us has access to a MinGW setup, so we cannot debug this problem. If you're hacking on dejagnu or expect itself (because it has not yet been ported to MinGW correctly or lacks features that we need on that host) you are outside of our area of our area of expertise. I suggest trying to dejagnu mailing list to see if anyone has run into this problem before.

Thanks,

-Chris

make check VERBOSE=1

which gave me this:
------------------
if test -d "/C/projects/build/MinGW/llvm-2-1/test" ; then \
if test -f "/C/projects/build/MinGW/llvm-2-1/test/Makefile" ; then \
  echo llvm[0]: Running test suite ; \
  make -C /C/projects/build/MinGW/llvm-2-1/test check-local \
    TESTSUITE= ; \
else \
  echo llvm[0]: No Makefile in test directory ; \
fi ; \
else \
echo llvm[0]: No test directory ; \
fi
llvm[0]: Running test suite
make[1]: Entering directory `/C/projects/build/MinGW/llvm-2-1/test'
PATH=/C/projects/build/MinGW/llvm-2-1/Debug/bin:/C/projects/src/llvm-2/llvm/test/Scripts:.:/usr/local/bin:/mingw/bin:/bin:/mingw/bin:/usr/bin:/c/LLVM/tools:/c/perl/5.8.5/bin:/c/perl/5.8.5/bin/MSWin32-x86-multi-thread:/mingw/lib/expect-5.21 \
/usr/local/bin/runtest
WARNING: Couldn't find the global config file. WARNING: No tool specified Test Run By llvm on Sun Jan 9 00:50:59 2005
Native configuration is i686-pc-mingw32

    === tests ===

Schedule of variations:
  unix

Running target unix
Using C:/MinGW/msys/local/share/dejagnu/baseboards/unix.exp as board description file for target.
Using C:/MinGW/msys/local/share/dejagnu/config/unix.exp as generic interface file for target.
WARNING: Couldn't find tool config file for unix, using default.
    === Summary ===

make[1]: Leaving directory `/C/projects/build/MinGW/llvm-2-1/test'
------------------

Obviously no tests has been run. Is my test system still buggy?

Henrik.

----Original Message Follows----
From: Tanya Lattner <tonic@nondot.org>
Reply-To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
To: LLVM Developers Mailing List <llvmdev@cs.uiuc.edu>
Subject: Re: [LLVMdev] make check fails on mingw
Date: Fri, 7 Jan 2005 14:55:04 -0600 (CST)

Well, doing a runtest in the test folder gave me these results:
-----------------
WARNING: Couldn't find the global config file. WARNING: No tool specified Test Run By llvm on Fri Jan 7 20:55:24 2005
Native configuration is i686-pc-mingw32

    === tests ===

ERROR: (DejaGnu) proc "exp_debug" does not exist. The error code is NONE The info on the error is: can't rename to "exp_tcl_continue": command already exists while executing "rename continue exp_tcl_continue"
    === Summary ===

You are running a pretty old version of expect (5.21 was released in 1996). I would upgrade it to start. I'm not sure if that will fix your problem though as I am not an expect expert :slight_smile:

Did you follow the instructions to test if Dejagnu was installed correctly?
http://www.gnu.org/software/dejagnu/manual/x199.html

If you are still having problems after getting the latest expect and following the instructions from the dejagnu manual, then I would post to their mailing list.

What is the global config file?

The warning about a global config file is normal and you should ignore it.

-Tanya

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

_________________________________________________________________
Få alle de nye og sjove ikoner med MSN Messenger http://messenger.msn.dk/

_______________________________________________
LLVM Developers mailing list
LLVMdev@cs.uiuc.edu http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

-Chris