Ubuntu 14.04 Trusty packages broken

Hello,

I don't know how it happened, but recent Ubuntu builds have broken -dev packages, which contain same libraries as non-dev packages.

dpkg: error processing archive /var/cache/apt/archives/libllvm3.5_1%3a3.5~svn207603-1~exp1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/llvm-3.5/lib/libLLVM-3.5.so', which is also in package llvm-3.5-dev 1:3.5~svn207603-1~exp1

dpkg: error processing archive /var/cache/apt/archives/clang-3.5_1%3a3.5~svn207603-1~exp1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/llvm-3.5/lib/clang/3.5.0/lib/linux/libclang_rt.tsan-x86_64.a', which is also in package libclang-common-3.5-dev 1:3.5~svn207339-1~exp1

I don't know where to file a bug or who's maintainer, but it would be great to fix that.

Thank you,

Cheers,

That would be my fault and the component in the bugzilla is Packaging/apt.

I am going to have a look to this. Sorry, I added recently some missing
files in the packages.

Sylvestre

It should be fixed. Can you confirm?

Thanks
Sylvestre

It should be fixed. Can you confirm?

Nope. Sorry. Still doesn't work here:

Get:3 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main libllvm3.5 amd64 1:3.5~svn207822-1~exp1 [7,300 kB]
Get:4 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main llvm-3.5-runtime amd64 1:3.5~svn207822-1~exp1 [52.0 kB]
Get:5 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main llvm-3.5 amd64 1:3.5~svn207822-1~exp1 [1,075 kB]
Get:6 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main llvm-3.5-dev amd64 1:3.5~svn207822-1~exp1 [11.1 MB]
Get:7 http://llvm.org/apt/trusty/ llvm-toolchain-trusty/main llvm-3.5-tools amd64 1:3.5~svn207822-1~exp1 [145 kB]
Fetched 19.8 MB in 8s (2,256 kB/s)
Selecting previously unselected package libllvm3.5:amd64.
(Reading database ... 202833 files and directories currently installed.)
Preparing to unpack .../libllvm3.5_1%3a3.5~svn207822-1~exp1_amd64.deb ...
Unpacking libllvm3.5:amd64 (1:3.5~svn207822-1~exp1) ...
Selecting previously unselected package libtinfo-dev:amd64.
Preparing to unpack .../libtinfo-dev_5.9+20140118-1ubuntu1_amd64.deb ...
Unpacking libtinfo-dev:amd64 (5.9+20140118-1ubuntu1) ...
Selecting previously unselected package llvm-3.5-runtime.
Preparing to unpack .../llvm-3.5-runtime_1%3a3.5~svn207822-1~exp1_amd64.deb ...
Unpacking llvm-3.5-runtime (1:3.5~svn207822-1~exp1) ...
Selecting previously unselected package llvm-3.5.
Preparing to unpack .../llvm-3.5_1%3a3.5~svn207822-1~exp1_amd64.deb ...
Unpacking llvm-3.5 (1:3.5~svn207822-1~exp1) ...
Selecting previously unselected package libffi-dev:amd64.
Preparing to unpack .../libffi-dev_3.1~rc1+r3.0.13-12_amd64.deb ...
Unpacking libffi-dev:amd64 (3.1~rc1+r3.0.13-12) ...
Preparing to unpack .../llvm-3.5-dev_1%3a3.5~svn207822-1~exp1_amd64.deb ...
Unpacking llvm-3.5-dev (1:3.5~svn207822-1~exp1) ...
dpkg: error processing archive /var/cache/apt/archives/llvm-3.5-dev_1%3a3.5~svn207822-1~exp1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/llvm-3.5/lib/libLLVM-3.5.so', which is also in package libllvm3.5:amd64 1:3.5~svn207822-1~exp1
Selecting previously unselected package llvm-3.5-tools.
Preparing to unpack .../llvm-3.5-tools_1%3a3.5~svn207822-1~exp1_amd64.deb ...
Unpacking llvm-3.5-tools (1:3.5~svn207822-1~exp1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for doc-base (0.10.5) ...
Processing 1 added doc-base file...
Processing triggers for install-info (5.2.0.dfsg.1-2) ...
Errors were encountered while processing:
/var/cache/apt/archives/llvm-3.5-dev_1%3a3.5~svn207822-1~exp1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Regards

I fixed it later. It should be ok now

Sylvestre

I am sorry, now there is an error with libclang vs libclang-dev:

dpkg: error processing archive /var/cache/apt/archives/libclang-3.5-dev_1%3a3.5~svn207969-1~exp1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/llvm-3.5/lib/libclang.so.1', which is also in package libclang1-3.5:amd64 1:3.5~svn207930-1~exp1

Regards,

Hi Sylvestre,

It seems that latest libllvm3.5 packages are built with too recent libstdc++ version which makes impossible to install any of llvm Ubuntu builds on <13.10

The following packages have unmet dependencies:
libllvm3.5 : Depends: libstdc++6 (>= 4.8) but 4.7.2-2ubuntu1 is to be installed

Can you please have a look? We still have guys have that haven't upgrade to latest LTS.

Cheers,

Clang requires GCC and libstdc++ 4.7+ now that we’ve switched to C++11:
http://llvm.org/docs/GettingStarted.html#host-c-toolchain-both-compiler-and-standard-library

We have instructions there for building a modern version of gcc. It’s really easy to build it these days. Install into something local like $HOME/gcc/install and then pass appropriate -L and -Wl,-rpath flags to the LLVM build. I do this on 12.04 and it works fine.

Clang requires GCC and libstdc++ 4.7+ now that we've switched to C++11:
http://llvm.org/docs/GettingStarted.html#host-c-toolchain-both-compiler-and-standard-library

Maybe I wasn't clear enough, but I just report that official http://llvm.org/apt/ Debian/Ubuntu 3.5 packages are broken for <13.10.

Do you confirm that you have also the backport installed?
deb http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu precise main
or
deb http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu quantal main

Cheers,
Sylvestre

I think we can narrow it down to the 12.10 which is used by one of the professors here @ my univ. There are no 12.10 gcc-4.8 builds unfortunately, take a look:
https://launchpad.net/~ubuntu-toolchain-r/+archive/test/+packages
https://launchpad.net/~ubuntu-toolchain-r/+archive/ppa/+packages

Guess this has to be noted somewhere, or maybe Ubuntu builds should stick to only supported Ubuntu versions, which makes 12.04, 13.10 & 14.04 I believe. Anyway we gonna upgrade all our workstations to 14.04 soon.

Regards,