phabricator review emails missing

Hi,

I've noticed a few times recently that phabricator doesn't seem to
send any email to llvm-commits for a particular llvm review. A recent
example is https://reviews.llvm.org/D102882. I have an email in my
inbox for the commit, but none for the review. The llvm-commits
archive seems to show the same.

Can anyone tell what's going on?

It's quite annoying for my workflow because I rely on email to tell me
when new patches come up, even though I do my actual reviews on
phabricator.

Thanks,
Jay.

Hey,

I’m not sure what’s going on, I tried to trigger a resend of the initial patch email but it does not seem to be working, I don’t know if there is something in this patch that makes the email malformed or something like that. From the Phabricator internals point of view the email gets sent, we would need to look on the SendGrid side if there is any log of anything, @Manuel Klimek you’re the only one with access here I believe?

In SendGrid, I see lots of delivered emails for [PATCH] D102882: …
but as best I can tell neither to Jay or Mehdi…

I got an email for this revision when I subscribed to it. However I triggered a resend of the initial email with the patch attached and I don’t expect to be subscribed to this one, but llvm-commits@ is subscribed and the email never made it to the lists.

In SendGrid, I see lots of delivered emails for [PATCH] D102882: …
but as best I can tell neither to Jay or Mehdi…

I got an email for this revision when I subscribed to it. However I triggered a resend of the initial email with the patch attached and I don’t expect to be subscribed to this one, but llvm-commits@ is subscribed and the email never made it to the lists.

Wondering whether this is a problem on the llvm-commits@ side - SendGrid claims it delivered to llvm-commits@lists.llvm.org.

In SendGrid, I see lots of delivered emails for [PATCH] D102882: …
but as best I can tell neither to Jay or Mehdi…

I got an email for this revision when I subscribed to it. However I triggered a resend of the initial email with the patch attached and I don’t expect to be subscribed to this one, but llvm-commits@ is subscribed and the email never made it to the lists.

Wondering whether this is a problem on the llvm-commits@ side - SendGrid claims it delivered to llvm-commits@lists.llvm.org.

Is it sitting in the moderation queue?

~Aaron

This may have been the case, everything just showed up, including the re-sends I triggered: https://lists.llvm.org/pipermail/llvm-commits/Week-of-Mon-20210517/920059.html